Không thể đăng nhập vào bảng điều khiển ePO (Lỗi 500 trong trình duyệt web)

Môi trường dữ liệu

  • McAfee ePolicy Orchestrator (ePO) 5.x

Sự cố

Bạn không thể đăng nhập vào bảng điều khiển ePO.

Trình duyệt web hiển thị lỗi sau khi bạn cố gắng truy cập bảng điều khiển ePO:

Error 500

Vấn đề

Orion.log ghi lại các lỗi sau đây:

Lỗi 1

Error [main] plugin.PluginManager – Khởi tạo lõi plugin không thành công.  org.springframework.beans.factory.BeanCreationException: Lỗi tạo bean với tên ‘core.ext.taskGlobals’ được xác định trong URL [jndi: /localhost/core/WEB-INF/beans.xml]: Không tạo được phương thức init; Exception lồng nhau là java.lang.IllegalStateException: Các tiện ích mở rộng sau ở trạng thái cài đặt một phần: [dlp_93100_help:]

Nguyên nhân: java.lang.IllegalStateException: Các tiện ích mở rộng sau ở trạng thái cài đặt một phần: [dlp_93100_help:]

Lỗi 2

Error [ main] plugin.PluginManager – Khởi tạo lõi plugin không thành công. org.springframework.beans.factory.BeanCreationException: Lỗi khi tạo bean với tên ‘core.db’ được xác định trong URL [jndi: /localhost/core/WEB-INF/beans.xml]: Không thể tạo bean; trùng nhau lệnh org.springframework.beans.BeanInstantiationException: Không thể khởi tạo lớp bean [com.mcafee.orion.core.db.base.Database]:Constructor tung ra Exception; Exception lồng nhau là java.sql.SQLException: Đăng nhập không thành công cho người dùng ”. Người dùng không được liên kết với kết nối SQL Server đáng tin cậy.

Nguyên nhân: org.springframework.beans.BeanInstantiationException: Không thể khởi tạo lớp bean [com.mcafee.orion.core.db.base.Database]:

Constructor tung ra Exception; Exception lồng nhau là java.sql.SQLException: Đăng nhập không thành công cho người dùng ”. Người dùng không được liên kết với kết nối SQL Server đáng tin cậy.

Nguyên nhân: java.sql.SQLException: Đăng nhập không thành công cho người dùng ”. Người dùng không được liên kết với kết nối SQL Server đáng tin cậy.

Nguyên nhân

Lỗi 500 trên bảng điều khiển ePO có hai nguyên nhân phổ biến:

  • Tiện ích mở rộng được cài đặt một phần

hoặc

  • Kết nối cơ sở dữ liệu

Để xác định nguyên nhân của sự cố này, hãy làm như sau:

  1. Khởi động lại dịch vụ máy chủ ứng dụng ePO.
  2. Đánh giá Orion.log.

LƯU Ý: Theo mặc định, orion.log được tìm thấy trong: ePO_installation_folder \ Server \ logs \

Sự cố phần mở rộng được cài đặt một phần: Orion.log hiển thị lỗi tương tự như sau:

ERROR [main] plugin.PluginManager – Khởi tạo lõi plugin không thành công.

Nguyên nhân: java.lang.IllegalStateException: Các tiện ích mở rộng sau ở trạng thái được cài đặt một phần: [dlp_93100_help:]

LƯU Ý: Lỗi trên chỉ ra rằng [dlp_93100_help:] nằm trong cơ sở dữ liệu bảng OrionExtensions, nhưng bị thiếu trong hệ thống tệp ePO.

Sự cố kết nối cơ sở dữ liệu – Orion.log hiển thị lỗi tương tự như sau:

Nguyên nhân: org.springframework.beans.BeanInstantiationException: Không thể khởi tạo lớp bean [com.mcafee.orion.core.db.base.Database]: Constructor đã tung ra Exception; Exception lồng nhau là java.sql.SQLException: Đăng nhập không thành công cho người dùng ”. Người dùng không được liên kết với kết nối SQL Server đáng tin cậy.

Nguyên nhân: java.sql.SQLException: Đăng nhập không thành công cho người dùng ”. Người dùng không được liên kết với kết nối SQL Server đáng tin cậy.

Giải pháp

Có hai cách để khắc phục sự cố này:

  • Nếu tiện ích mở rộng được báo cáo lỗi không cần thiết, hãy xóa nó khỏi hệ thống tệp và cơ sở dữ liệu ePO.

Trong cơ sở dữ liệu, hãy chạy truy vấn sau để xóa mục nhập:

Xóa khỏi OrionExtension where name = ‘dlp_93100_help’

QUAN TRỌNG: Trước khi bạn thay đổi bất kỳ điều gì trong cơ sở dữ liệu, hãy đảm bảo rằng có một bản sao lưu đầy đủ của cơ sở dữ liệu.

    • Tìm thư mục dlp_93100_help.xml \ Server \ Conf \ Catalina \ localhost. Nếu nó hiện diện, hãy chuyển nó ra màn hình nền.
    • Tìm thư mục dlp_93100_help trong \ Server \ Extensions \ Installed. Nếu nó hiện diện, hãy chuyển nó ra màn hình nền.
  • Vì phần mở rộng đã có trong cơ sở dữ liệu, hãy tìm trong hệ thống tệp. Tìm xem nó bị thiếu ở đâu và đặt bản sao của tệp hoặc thư mục vào vị trí được chỉ định.
    • Tìm dlp_93100_help.xml trong \ Server \ Conf \ Catalina \ localhost. Nếu nó bị thiếu, hãy sao chép phần mở rộng .xml từ bản sao lưu hoặc máy chủ ePO khác sang máy chủ ePO bị ảnh hưởng. Đảm bảo đúng phiên bản và đường dẫn cài đặt. Đường dẫn cài đặt trong tệp .xml phải khớp với đường dẫn cài đặt của máy chủ ePO bị ảnh hưởng.
    • Đảm bảo rằng thư mục dlp_93100_help trong \ Server \ Extensions \ Installed tồn tại. Nếu nó bị thiếu, hãy sao chép thư mục từ bản sao lưu hoặc máy chủ ePO khác sang máy chủ ePO bị ảnh hưởng.

Giải pháp

Để khắc phục sự cố kết nối cơ sở dữ liệu, hãy bắt đầu với kiểm tra UDL. Đảm bảo rằng tất cả thông tin trong DB.properties là chính xác.

Đảm bảo rằng tài khoản có quyền chính xác. Xác minh rằng tài khoản được sử dụng để truy cập SQL Server có các quyền sau:

1.Cơ sở dữ liệu mặc định phải là Master:

a.Nhấp vào Start, Programs, Microsoft SQL Server, SQL Server Management Studio.

b.Mở rộng Bảo mật, Đăng nhập.

c.Nhấp chuột phải vào tài khoản và chọn Thuộc tính.

d.Đảm bảo rằng cơ sở dữ liệu mặc định được đặt thành Master.

e.Mở rộng Bản đồ người dùng và đảm bảo rằng tài khoản có dbo trong lược đồ cho cơ sở dữ liệu.

2.Tài khoản này phải có db_owner trong thuộc tính bảo mật cơ sở dữ liệu:

a.Bấm Bắt đầu, Chương trình, Microsoft SQL Server, SQL Server Management Studio.

b.Mở rộng Cơ sở dữ liệu, cơ sở dữ liệu ePO của bạn, Bảo mật, Người dùng.

c.Nhấp chuột phải vào tài khoản dbo và chọn Thuộc tính.

d.Đảm bảo rằng tài khoản có dbo trong Mặc định cho cơ sở dữ liệu.

LƯU Ý: Nếu bạn sử dụng tài khoản NT để xác thực với cơ sở dữ liệu ePO, hãy đảm bảo rằng tài khoản có quyền quản trị viên Cục bộ trên máy chủ ePO.

3.Đảm bảo rằng Tự động Đóng được đặt thành Sai cho cơ sở dữ liệu ePO:

a.Nhấp vào Bắt đầu, Chương trình, Microsoft SQL Server, SQL Server Management Studio.

b.Bấm chuột phải vào cơ sở dữ liệu ePO và chọn Thuộc tính.

c.Nhấp vào Tùy chọn và đảm bảo rằng Tự động Đóng được đặt thành False. Nếu không, hãy nhấp vào Tự động đóng, chọn False và nhấp vào OK.

4.Đảm bảo rằng dịch vụ trình duyệt SQL đang chạy:

a.Bấm Bắt đầu, Chạy, nhập msc và bấm OK.

b.Định vị dịch vụ Trình duyệt SQL Server và đảm bảo rằng nó đã khởi động và đang chạy. Nếu không, hãy bấm chuột phải vào dịch vụ Trình duyệt SQL Server và bấm Bắt đầu.

5.Đảm bảo rằng Mã hóa Lực lượng SQL bị tắt trong môi trường Máy chủ SQL. Nếu nó được bật:

a.Nhấp vào Bắt đầu, Tất cả chương trình, Công cụ cấu hình, Trình quản lý cấu hình máy chủ SQL.

b.Bấm chuột phải vào Giao thức cho (MSSQLSERVER theo mặc định) trong Cấu hình mạng máy chủ SQL và bấm Thuộc tính.

c.Nhấp vào danh sách thả xuống cho Buộc mã hóa và chọn Không.

d.Nhấp vào OK.

6.Kích hoạt TCP / IP trên máy chủ ePO:

a.Nhấp vào Bắt đầu, Chạy, nhập cliconfg và nhấp vào OK.

b.Đảm bảo rằng giao thức TCP / IP được Bật và ở đầu danh sách các giao thức Đã bật theo thứ tự.

7.Đối với môi trường IPv6. Đảm bảo rằng chỉ IPv6 được bật trên SQL Server lưu trữ cơ sở dữ liệu ePO.

Cách giải quyết

QUAN TRỌNG: Trước khi bắt đầu quy trình được giải thích trong bài viết này, bạn phải sao lưu máy chủ ePO của mình.

Nếu các tiện ích mở rộng đang được sử dụng và một bản sao tốt không tồn tại trên thư mục, hãy sử dụng các bước bên dưới để điều tra và giải quyết các tiện ích mở rộng không khớp.

Xem lại các vị trí dưới đây trên máy chủ ePO và trong bảng Cơ sở dữ liệu ePO, để xác định vị trí tồn tại sự không khớp. So sánh số tiện ích mở rộng sản phẩm được quản lý (phiên bản) giữa các vị trí.

1.Vị trí: .. \ ePolicy Orchestrator \ Server \ Extensions \ install \

LƯU Ý: Các thư mục ở vị trí này có thể chứa nhiều thư mục con hơn. Số thích hợp nhất được sử dụng là số cao nhất trên thư mục. Ví dụ: thư mục Mcafee Agent EPOAGENTMETA có thể chứa một số thư mục con, ví dụ:

  • 5.1.124
  • 7.2.131
  • 7.3.200

Trong trường hợp trên, 5.7.3.200 được dịch vụ Ứng dụng ePO sử dụng khi khởi động bảng điều khiển.

2.Vị trí: .. \ ePolicy Orchestrator \\ Server \ conf \ Catalina \ localhost \

Ở vị trí trên, có một tệp (.xml) tham chiếu đến vị trí trong bước 1. Ví dụ: Tác nhân Mcafee (EPOAGENTMETA). (.Xml) phải tham chiếu cùng một phiên bản được tìm thấy trong bước 1 ở trên.

3.Trên chính Cơ sở dữ liệu ePO, hãy sử dụng truy vấn bên dưới để hiển thị các phiên bản Tiện ích mở rộng:

Chọn * từ OrionExtensions Order theo Tên ASC;

So sánh các vị trí và xác định bất kỳ sự không khớp nào. Nếu chỉ tìm thấy một điểm không khớp, trường hợp này có thể được sửa chữa.

Lỗi phổ biến nhất tồn tại trong thư mục \ ePolicy Orchestrator \ Server \ Extensions \ install \. Nơi một thư mục cao hơn được tạo, nhưng xml và phiên bản trên Cơ sở dữ liệu thấp hơn. Trong trường hợp này, chỉ cần di chuyển thư mục đến một vị trí khác và khởi động lại dịch vụ Ứng dụng ePO.

a.Nhấn phím Windows + R.

b.Nhập msc vào trường và nhấn Enter.

c.Nhấp chuột phải vào dịch vụ ePO bên dưới và chọn Khởi động lại:

McAfee ePolicy Orchestrator #. #. # Application server

d.Đóng cửa sổ dịch vụ

Trân trọng cám ơn quý độc giả.

Biên dịch Lê Toản – Help.pacisoft.com