Cùng PACISOFT VN Help Center và Veeam tìm hiểu cách khắc phục lỗi khi cài đặt Veeam “Selected … port is not available”
Khó khăn
Trong quá trình cài đặt các ứng dụng của Veeam lần đầu, install wizard có một trang chỉ định các service port. Khi chuyển sang trang tiếp theo của install wizard, lỗi “Selected … port is not available” có thể xuất hiện.
Các ví dụ lỗi cụ thể đối với từng sản phẩm của Veeam như sau:
Veeam Backup & Replication
- Selected Veeam Backup Catalog service port is not available.
- Selected Veeam Backup & Replication service port is not available.
- Selected Veeam Backup & Replication secure connections port is not available.
- Selected RESTful API service port is not available.
Veeam Backup Enterprise Manager
- Selected website HTTP port is not available.
- Selected website HTTPS port is not available.
- Selected Veeam Backup Restful API service HTTP port is not available.
- Selected Veeam Backup Restful API service HTTPS port is not available.
- Selected Veeam Backup Enterprise Manager service port is not available.
- Selected Veeam Backup Catalog service port is not available.
Nguyên nhân
Khi nhấp vào [Tiếp theo] trên trang cài đặt nơi xác định các port, trình cài đặt sẽ kiểm tra xem các specified ports có đang được sử dụng hay không. Cửa sổ Lỗi sẽ hiển thị khi một port đang được sử dụng.
Giải pháp
Xác định và ngắt quá trình sử dụng port liên quan đến lỗi, sau đó tiến hành cài đặt phần mềm Veeam.
PowerShell script sau có thể được sử dụng để xác định process identifier number (PID) và process name đang sử dụng specified port.
- Get-Process -Id (Get-NetTCPConnection -LocalPort 9393).OwningProcess | ft Id,ProcessName
Đối với các môi trường mà PowerShell đã bị vô hiệu hóa, sử dụng script sau.
- netstat -nbao | find “9393”
Các ví dụ trên dành cho lỗi “Selected Veeam Backup Catalog service port is not available.” và giả sử default port là 9393.
Biên dịch bởi Ngọc Diệu – Pacisoft.com