Lỗi “Object reference not set to an instance of an object” khi sao lưu Microsoft Teams với Veeam

Cùng PACISOFT VN Help Center tìm hiểu Lỗi “Object reference not set to an instance of an object” khi sao lưu Microsoft Teams.

Khó khăn

Sao lưu Microsoft Teams trong Veeam Backup for Microsoft Office 365 không thành công với lỗi sau:

Error: Object reference not set to an instance of an object.

Nguyên nhân

Lỗi này liên quan đến những thay đổi gần đây trong response syntax của Microsoft Graph API cho một yêu cầu cụ thể của Veeam Backup for Microsoft Office 365 đối với Microsoft Teams.

Giải pháp

Kiểm tra độ tương thích – Hotfix Compatibility

  • Hotfix này chỉ tương thích với Veeam Backup for Microsoft Office 365 phiên bản 5c (bản dựng 5.0.2.22).  Bạn phải nâng cấp trước khi cài đặt hotfix.
  • Hotfix này chỉ giải quyết sự cố trong trường hợp này. Nếu một hotfix khác đã được cài đặt, không cài đặt hotfix này. Hãy liên hệ với bộ phận Hỗ trợ của Veeam và Veeam sẽ cung cấp cho bạn một cumulative hotfix.

Cài đặt Hotfix

Bước 1: Dừng tất cả việc sao lưu

Bước 2: Kết thúc tất cả các phiên Khôi phục đang hoạt động (nếu có)

Bước 3: Dừng các Dịch vụ sau trên Veeam Backup for Microsoft Office 365 server

  • Veeam Backup for Microsoft Office 365 Service
  • Veeam Backup Proxy for Microsoft Office 365 Service
  • Veeam Backup for Microsoft Office 365 RESTful API Service

Bước 4: Tải hotfix được đề cập trong bài viết này.

Bước 5: Giải nén nội dung của tệp ZIP vào thư mục C: \ Temp.

Bước 6: Chạy lệnh sau trong Windows PowerShell bằng chế độ Admin để xóa khóa bảo mật:

  • Get-ChildItem -Path “C: \ temp \ KB4201_20210826 \” -Recurse -Force | Bỏ chặn-Tệp

Bước 7: Trên Veeam Backup for Microsoft Office 365 controller server, hãy tìm Veeam.Graph.Teams.dll và Veeam.Archiver.Source.dll trong mỗi thư mục được liệt kê bên dưới. Đổi tên các dlls ban đầu hoặc di chuyển chúng sang một thư mục khác, sau đó sao chép Veeam.Graph.Teams.dll và Veeam.Archiver.Source.dll từ thư mục Hotfix vào:

  • C: \ Program Files \ Veeam \ Backup365
  • C: \ Program Files \ Veeam \ Backup365 \ Packages \ Proxy

Bước 8: Trên các máy chủ đã cài đặt Veeam Explorer for Microsoft Teams, hãy tìm file Veeam.Teams.Restore.dll và Veeam.Graph.Teams.dll trong thư mục được liệt kê bên dưới. Đổi tên các dlls ban đầu hoặc di chuyển chúng sang một thư mục khác, sau đó sao chép Veeam.Teams.Restore.dll và Veeam.Graph.Teams.dll từ thư mục Hotfix vào:

  • C: \ Program Files \ Veeam \ Backup and Replication \ Explorers \ Teams

Bước 9: Bắt đầu các dịch vụ đã dừng ở Bước 3

Bước 10: Nâng cấp backup proxy servers bằng cách sử dụng Veeam Backup for Microsoft Office 365 console.

Bước 11: Chạy sao lưu dữ liệu Microsoft Teams và kiểm tra xem còn gặp lỗi này hay không.

Nếu sự cố vẫn tiếp diễn sau khi cài đặt hotfix, vui lòng collect log files và liên hệ bộ phận Hỗ trợ Veeam.

Download hotfix ở đây.

Biên dịch bởi Ngọc Diệu – Pacisoft.com