Trend Micro: Sửa lỗi mất tác nhân trên trình điều khiển web khi chuyển từ OfficeScan XG sang Apex One

TÓM TẮT

Sau khi chuyển tác nhân từ máy chủ OfficeScan XG sang một máy chủ Apex One:

  • Tác nhân đó không hiển thị trên bảng điều khiển web của OfficeScan XG
  • Tác nhân không hiện trên bảng điều khiển web của Apex One

HƯỚNG DẪN CHI TIẾT

Sau đây là các trường hợp có thể dẫn đến lỗi trên và giải pháp tương ứng:


Trường hợp 1

> Nguyên nhân

Cả bảng điều khiển trang web của Apex One và Apex Central được cài đặt trên cùng thiết bị máy chủ và đều sử dụng trang web mặc định.

> Kết quả

Từ nhật kí ISS của máy chủ Apex One, cổng HTTP cho isapiClient.dll báo lỗi 500:
fe80::3d1c:256b:bbc:7b7e%3 POST /officescan/cgi/isapiClient.dll – 443 – fe80::3d1c:256b:bbc:7b7e%3 62691CB3BF62DAF233FB2C02782E7BD2+HTTP/1.1 – 500 0 193 0

-> Tập tin nhật kí ISS nằm trong thư mục C:\inetpub\LogFiles\W3SVC1 nếu Apex One sử dụng trang web mặc định và C:\inetpub\LogFiles\W3SVC3 nếu Apex One sử dụng thư mục ảo.

  • Khi Apex Central và Apex One đều sử dụng trang web mặc định và cài đặt trên cùng một máy chủ, chúng sẽ sử dụng cùng một
  • Apex Central cần được định cấu hình cài đặt: IISApplication Pools > DefaultAppPool > Advanced Settings > Enable 32-Bit Application > True.
  • Mặt khác, Apex One cần cấu hình sau: IIS > Application Pools > DefaultAppPool > Advanced Settings > Enable 32-Bit Application > False by default.

Điều này gây lỗi kết nối tác nhân bởi vì theo mặc định, Apex One sử dụng phiên bản 64-bit của tập tin \Trend Micro\OfficeScan\PCCSRV\Web_OSCE\Web\CGI\isapiClient.dll

> Giải pháp

Giải pháp đề xuất là một trong 2 cách sau:

  • Cài đặt máy chủ Apex One trên một máy chủ khác.
  • Cài máy chủ Apex One trên cùng một máy, nhưng sử dụng thư mục ảo thay vì trang web mặc định trong lúc cài đặt.
> Xác thực

Để kiểm tra lỗi đã được khắc phục:

  • Bây giờ bạn đã có thể di chuyển tác nhân/ máy trong Apex One web consoleAgents > Agent Management.
  • https://<Apex One FQDN or IP Address>/officescan/cgi/isapiClient.dll sẽ hiển thị 1 trong 2 kết quả khi truy cập từ trình duyệt trên máy tính của tác nhân:
    • Trên Internet Explorer, sẽ hiện quả “-1” khi truy cập https://<Apex One FQDN or IP Address>/officescan/cgi/isapiClient.dll.

    • Trên Google Chrome, tập tin  isapiClient.dll có thể được tải xuống từ trình duyệt.


Trường hợp 2

> Nguyên do

Nhiều hơn 2 tác nhân có thể sử dụng cùng UID trên cơ sở dữ liệu, nếu máy công cụ chuyển máy chủ không được sử dụng.

> Kết quả

Trong phần này, ‘OSCEXGSP1SVR12‘ sẽ là ví dụ cho tác nhân bị mất. Tác nhân được chuyển (OSCEXGSP1SVR12) không hiện trong cây miền quản lý tác nhân trong bảng điều khiển web Apex One.

Khi được tìm, có thể thấy tác nhân được chuyển sang nhưng không thể di dời.

Dưới đây sẽ là cấu trúc miền của tác nhân được ví dụ và sẽ là cơ sở cho quá trình tìm kiếm.

Để bắt đầu khắc phục sự cố, đi đến máy chủ SQL nơi lưu trữ có sở dữ liệu Apex One. Sử dụng Microsoft SQL Server Management Studio để truy cập cơ sở dữ liệu máy chủ Apex One, sau đó thực hiện bước sau:

  1. Chuột phải vào cơ sở dữ liệu của Apex One, chọn New Query.
  2. Kiểm tra miền phụ mà tác nhân bị mất ‘OSCEXGSP1SVR12’ đăng kí hoặc đang báo cáo. Sử dụng lệnh bên dưới:
    SELECT * FROM TBL_CLIENT_INFO WHERE COMP_NAME = ‘OSCEXGSP1SVR12’
  1. Sử dụng lệnh sau để xác thực đâu mới là miền mẹ chính xác của miền phụ ‘Hans1’:
    SELECT * FROM TBL_CLIENT_INFO WHERE COMP_NAME = ‘Hans1’

Truy vấn miền phụ ‘Hans1’ cho thấy, có hai miền mẹ (Hansq) với tên giống nhau nhưng khác DOMAIN_UIDs.

  1. Sử dụng lệnh dưới, miền mẹ ‘Hansq’ có thể được truy vấn, và sẽ hiện rằng chỉ có một miền mẹ tên ‘Hansq’ được đăng kí trong miền gốc, và UID là ’60C1BB05-6715-414C-BA5A-71FAB0326830′
    SELECT * FROM TBL_CLIENT_INFO WHERE COMP_NAME = ‘Hansq’

Vì vậy, DOMAIN_UID chính xác của tác nhân ‘OSCEXGSP1SVR12’ là ‘399BA356-A141-4F9F-ABEF-7F8B09CED138’, là UID của miền phụ đúng ‘Hans1’ mà lẽ ra tác nhân bị mất phải báo cáo đến.

-> Ghi nhớ DOMAIN_UID (hộp màu xanh) đúng của tác nhân, bởi vì nó sẽ được dùng để sửa lỗi. (Bảng giá trị ở trên CHỈ là ví dụ và có thể khác tùy theo môi trường hệ thống)

Dựa trên tình huống trên, tác nhân được đặt dưới miền phụ trùng lặp với một UID khác. Miền mẹ của miền phụ trùng lặp này không tồn tại trong cơ sở dữ liệu của máy chủ, đó là lí do tác nhân không hiện trong cây quản lý tác nhân của trình điều khiển Apex One.

Thông thường, nguyên nhân là do tạo miền thủ công với cùng tên từ nguồn máy chủ. Để thực hiện chuyển tác nhân từ OfficeScan sang Apex One thành công, điều quan trọng là sử dụng Công cụ chuyển máy chủ để nó có thể sao chép cấu trúc miền cũng như các cài đặt của nó.

-> Công cụ chuyển máy chủ không sao lưu danh sách Tác nhân bảo mật của của máy chủ OfficeScan

> Giải pháp

Sử dụng thông tin mẫu được thu thập từ mục Kết quả, chúng ta sẽ cập nhật cơ sở dữ liệu để sửa DOMAIN_UID của tác nhân bị ảnh hưởng.

  1. Dựa theo mục Kết quả, chúng ta có thể xác định DOMAIN_UID của tác nhân mẫu ‘OSCEXGSP1SVR12’ là sai
    SELECT * FROM TBL_CLIENT_INFO WHERE COMP_NAME = ‘OSCEXGSP1SVR12’

  1. Để sửa, chúng ta nên sử dụng DOMAIN_UID chính xác của tác nhân đã được ghi trong bước cuối cùng của mục Kết quả.

 

Sử dụng lệnh bên dưới để cập nhật đúng DOMAIN_UID cho tác nhân.
UPDATE TBL_CLIENT_INFO set DOMAIN_UID=’399BA356-A141-4F9F-ABEF-7F8B09CED138′ WHERE COMP_NAME=’OSCEXGSP1SVR12′;

-> Các giá trị của DOMAIN_UID và COMP_NAME từ lệnh SQL bên trên được dựa trên thông tin thu thập được từ mục Kết quả và CHỈ có mục đích làm ví dụ. Điều này có thể khác tùy vào môi trường hệ thống của bạn

  1. Sau khi thực hiện lệnh SQL, DOMAIN_UID của tác nhân bây giờ sẽ chính xác.

Bằng cách đổi DOMAIN_UID của tác nhân bị ảnh hưởng, tác nhân hiện đã được đặt dưới đúng miền phụ.

> Xác thực

Để xác minh lỗi đã được sửa:

  • Tác nhân sẽ xuất hiện dưới đúng miền
  • Đã có thể di dời tác nhân.


Biên dịch bởi Thanh Hiền – Help.pacisoft.com